Moderators: Derry, Goldie, Harpo
Go
New
Find
Notify
Tools
Reply
  
Web Page Too Long
 Login/Join
 
Junior Mechanic
posted
It scrolls for miles after my content is done, on all pages.
Why?
What can I do about it?
Any help would be appreciated.
Thanks.
 
Posts: 9 | Registered: September 07, 2010Reply With QuoteReport This Post
Guru 'Geezer' Mechanic
Picture of larryd
posted Hide Post
Without seeing your site pages, it is hard to say.

Best guess is that you have some object way out of position that is causing your page to be too long. If you have any code objects common to your pages, it could be an error in the coding.

If you give a link to your site, someone can look at maybe can give you specifics.
 
Posts: 9235 | Registered: December 03, 2006Reply With QuoteReport This Post
Guru 'Power' Mechanic
Picture of Bruceee
posted Hide Post
Try the Select All Below function to snag anything beyond your intended bottom -- then delete or whatever.
 
Posts: 11363 | Location: Wellington, New Zealand | Registered: December 11, 2003Reply With QuoteReport This Post
Junior Mechanic
posted Hide Post
quote:
Originally posted by larryd:
Without seeing your site pages, it is hard to say.

Best guess is that you have some object way out of position that is causing your page to be too long. If you have any code objects common to your pages, it could be an error in the coding.

If you give a link to your site, someone can look at maybe can give you specifics.




THANKS FOR THE SPEEDY REPLY, LARRYD,

Sorry it took me so long to respond. Having some computer problems. Anyway, here I am, here's the website:
http://grandsolar.net/

Just re-did & reposted the whole site, still miles long. I checked all the settings I could, to no avail. Couldn't find any stray objects. Any other ideas? Any help much appreciated.
K.
 
Posts: 9 | Registered: September 07, 2010Reply With QuoteReport This Post
Junior Mechanic
posted Hide Post
quote:
Originally posted by Bruceee:
Try the Select All Below function to snag anything beyond your intended bottom -- then delete or whatever.


quote:
Originally posted by larryd:
Without seeing your site pages, it is hard to say.

Best guess is that you have some object way out of position that is causing your page to be too long. If you have any code objects common to your pages, it could be an error in the coding.

If you give a link to your site, someone can look at maybe can give you specifics.



THANKS FOR THE SPEEDY REPLY, BRUCEEE,

Sorry it took me so long to respond. Open Office and/or my MS Installer/ Add/Delete Programs is bugging out on me.

Great tip about the Select All, never noticed that before. Nothing showed up though, checked all three sides all the way up & down. Any other ideas? Any help much appreciated.
K.
 
Posts: 9 | Registered: September 07, 2010Reply With QuoteReport This Post
Honorary 'Creative' Mechanic
Picture of Klimt
posted Hide Post
Your text/link object obj378 is causing the scrolling. The offending object is way down and right:
left: 10818.40em; top: 36267.90em;

You can either follow Bruce's instruction above or find obj378 from the drop-down list and move it to another position on the page or delete it.
 
Posts: 2693 | Location: Vienna, Austria | Registered: July 17, 2006Reply With QuoteReport This Post
Junior Mechanic
posted Hide Post
quote:
Originally posted by Klimt:
Your text/link object obj378 is causing the scrolling. The offending object is way down and right:
left: 10818.40em; top: 36267.90em;

You can either follow Bruce's instruction above or find obj378 from the drop-down list and move it to another position on the page or delete it.



Hi, Thanks, Klimt,

You're a life saver!

Odd that this artifact showed up at the extreme bottom right of the page in a browser but not in SiteSpinner, even in the Preview mode. Bug#1.

Bug#2 is that something I had previously deleted showed up completely off the workspace, invisible to me on SiteSpinner, but not to my viewers on the 'Net. I couldn't see it because it was at Verticle 300,000 something, and the workspace only goes down to 6,000 something. Definite glitch in the proggie, Virtual boffins, take heed.

The really bad part of this is that you can't see the problem until you go public with it. Makes you look bad. And you can only fix it by opening the Code View Window and doing a text search [control "F"] for an unique term in the offending objects text. It would have been easier to search if it had been a pure graphic, if I could have found the OBJ number on the web.

Did I say "easy"? NOT! Part of the problem is that you get this big long scrolling list of OBJs, but no clue as to which is which unless you have the OBJ number, click on it, and then check the Object Editor to see what it is. T - E - D - I - O - U - S ! ! !

And I went through the files in the CSS, GEOMETRY and OBJECTS folders, but the stray extra-workspace object was not visible anywhere. Where are text objects kept, O Mighty Oz? Not that I ever want to do this again . . .

Thanks again to the inestimable LarryD, Brucee, and Klimt. This program would be much less useful without the help of you folks. I hope you are somehow being compensated by the moguls at Virtual Mechanics. You hear that, Moguls?

K.
 
Posts: 9 | Registered: September 07, 2010Reply With QuoteReport This Post
Guru 'Geezer' Mechanic
Picture of larryd
posted Hide Post
quote:
The really bad part of this is that you can't see the problem until you go public with it.
The problem should also be apparent if you previewed the project.

Once the problem is detected, using Bruceee's suggestion would have found anything outside the designed target resolution.

Really not so hard at all.
 
Posts: 9235 | Registered: December 03, 2006Reply With QuoteReport This Post
Junior Mechanic
posted Hide Post
quote:
Originally posted by larryd:
quote:
The really bad part of this is that you can't see the problem until you go public with it.
The problem should also be apparent if you previewed the project.

Once the problem is detected, using Bruceee's suggestion would have found anything outside the designed target resolution.

Really not so hard at all.



Wow, that explains the foto!

Obviously, I did preview the whole site several times before putting it up on the Web, in SiteSpinners Preview and in my Web browser, as I said. But since those deleted text objects (there were actually two of them, one way, way right) were off the work area, as far as 300,000+ Vertical and 80,000 Horizontal, they were not visible until all the pages were uploaded to the web-host's server. THEN they were visible.

It's a glitch in the program, as I also pointed out for the benefit of all, and it needs to be fixed. Sorry if you have a problem with that which you feel requires adolescent sarcasm, LarryD. Deleted objects should not show up again anywhere, much less in invisible regions off the workspace AND the preview areas. Get it?

Brucee's suggestion, though good and much appreciated, did not work in this case: The objects could not be selected and deleted because they were not in the workspace. But thanks again, Bruceee, you're a gentleman & a scholar. VM needs to fix this.

Thanks again to Roma for finding the problem and being so helpful, gracious and positive in her response.
 
Posts: 9 | Registered: September 07, 2010Reply With QuoteReport This Post
Guru 'Geezer' Mechanic
Picture of larryd
posted Hide Post
You're right. I'm a total ignoramus and don't now what I'm talking about. I should have kept my fingers off the keyboard.

Mea culpa.
 
Posts: 9235 | Registered: December 03, 2006Reply With QuoteReport This Post
Honorary 'Aussie' Mechanic
posted Hide Post
Larry, if you are a “total ignoramus” then most of us here on this forum are complete nincompoops.

Another thing “kokonuts” may not know about is going to Edit > Clean Components. That can often get rid of those “stray” objects that just won’t go away.
 
Posts: 1804 | Location: Newcastle, Australia | Registered: April 17, 2007Reply With QuoteReport This Post
Guru 'Power' Mechanic
Picture of Bruceee
posted Hide Post
quote:
Brucee's suggestion, though good and much appreciated, did not work in this case: The objects could not be selected and deleted because they were not in the workspace.
Select All Below does work for objects outside the visible workpage -- that is why it is very useful in cases like this. You may have to look at the status bar to see what you have caught. Whatever you have caught, the Del key should remove it. Another option is to use the Quick Editor to set sensible XY co-ordinates.

I agree with Larry that the problem should have showed in preview -- had you noticed it then! But it's not something that you would necessarily spot if you were not looking for it.

We have never nailed down the cause of misplaced objects -- it may be mouse glitches. Whatever the cause, it seems reasonable for SiteSpinner to apply a sanity check when placing objects, and perhaps refuse to place them outside the workspace unless you explicitly ask.
 
Posts: 11363 | Location: Wellington, New Zealand | Registered: December 11, 2003Reply With QuoteReport This Post
Junior Mechanic
posted Hide Post
quote:
Originally posted by postyr:
Larry, if you are a “total ignoramus” then most of us here on this forum are complete nincompoops.

Another thing “kokonuts” may not know about is going to Edit > Clean Components. That can often get rid of those “stray” objects that just won’t go away.



Yes, I did that. It didn't work. It's a glitch in the program that needs to be fixed. Add that to your knowledge, if it please you.
 
Posts: 9 | Registered: September 07, 2010Reply With QuoteReport This Post
Junior Mechanic
posted Hide Post
quote:
Originally posted by Bruceee:
quote:
Brucee's suggestion, though good and much appreciated, did not work in this case: The objects could not be selected and deleted because they were not in the workspace.
Select All Below does work for objects outside the visible workpage -- that is why it is very useful in cases like this. You may have to look at the status bar to see what you have caught. Whatever you have caught, the Del key should remove it. Another option is to use the Quick Editor to set sensible XY co-ordinates.

I agree with Larry that the problem should have showed in preview -- had you noticed it then! But it's not something that you would necessarily spot if you were not looking for it.

We have never nailed down the cause of misplaced objects -- it may be mouse glitches. Whatever the cause, it seems reasonable for SiteSpinner to apply a sanity check when placing objects, and perhaps refuse to place them outside the workspace unless you explicitly ask.



No, Selecting All Below, Selecting All Right and Selecting All Left (one at a time) and then Deleting did not work, for the third time mentioning it here. Yes, it should have. Yes, I did look, very carefully, in Preview, and in my test browser, but the stray text objects did not appear until publication on the 'Net. In fact, the second OBJ did not appear until I laboriously found & deleted the first one, as described above. And the problem was with delete in the first place: I had deleted those objects, I didn't "set unreasonable coordinates." Why would I? The program screwed up. Period. I hope they fix it rather than trying to find something else to blame.

Thanks again to Roma for the actual solution.
 
Posts: 9 | Registered: September 07, 2010Reply With QuoteReport This Post
Guru 'Power' Mechanic
Picture of Bruceee
posted Hide Post
If you still have a copy of your project (the .ims file) with the invisible objects, I'm sure VM would be interested in seeing it -- and I would too.
 
Posts: 11363 | Location: Wellington, New Zealand | Registered: December 11, 2003Reply With QuoteReport This Post
Junior Mechanic
posted Hide Post
quote:
Originally posted by Bruceee:
If you still have a copy of your project (the .ims file) with the invisible objects, I'm sure VM would be interested in seeing it -- and I would too.



Didn't save it. Will next time, if it ever happens again. Thanks.
 
Posts: 9 | Registered: September 07, 2010Reply With QuoteReport This Post
  Powered by Social Strata  
 


™ & © 1998 - 2013, Virtual Mechanics Inc. All rights reserved.